Gtk-WARNING **: Unable to locate loadable module in module_path: "libthinice.so",

apt-get install gtk-engines-thinice

Gtk-WARNING **: Unable to locate loadable module in module_path: "libredmond95.so

apt-get install gtk-engines-redmond95


===============================

2009.03.13

Using gsview, I have two warning messages :
Gdk-WARNING **: locale not supported by C library
Gtk-WARNING **: Unable to locate loadable module in module_path: "libclearlooks.so",

The second one can be removed by "mv ~/.gtkrc ~/gtkrc or rm .gtkrc
or
look at the directory in /usr/share/themes/ and find one theme has "themename/gtk/gtkrc".
In my case, "/usr/share/themes/ThinIce/gtk/gtkrc"
* emacs ~/.gtkrc &
* delete all lines and add the following lines.
iclude "/usr/share/themes/ThinIce/gtk/gtkrc"

style "default-style"
{
}

class "*" style "default-style"

Then Gtk-WARNING **: Unable to locate loadable module in module_path: "libclearlooks.so", warning will be disappeared. Note that you should not use gtkrc file in gtk-2.0 directory.

If you do not like a default font of which the theme you selected, for me ThinIce, you can change by

include "/usr/share/themes/ThinIce/gtk/gtkrc"

style "userdefined-font"
{
  fontset = "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-*"
}

class "*" style "userdefined-font"
Of course you can find a right font by xfontsel
posted by citadel