Compilation

To compile the sources of gsview-4.9, gtk-config is necessary.

apt-get install libgtk1.2-dev
wget -c http://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/gsv49src.zip

  unzip -aa gsv49src.zip
  unzip -o gsv49src.zip "gsview-4.9/binary/*"
  cd gsview-4.9
  cp srcunx/unx.mak Makefile
  make

cd gsview-4.9/bin/
gsview*  gvxct.htm  gvxde.htm  gvxen.htm  gvxes.htm  gvxfr.htm  gvxgr.htm  gvxit.htm  gvxnl.htm  gvxru.htm  gvxse.htm  gvxsk.htm

check your gs version
~$ gs -version
GPL Ghostscript 8.61 (2007-11-21)
Copyright (C) 2007 Artifex Software, Inc.  All rights reserved

Options -> Advanced Configure.. ->

Ghostscript Version -> 861
Ghostscript Shared Object : libgs.so.8

-> OK

Options -> Save Settings Now

The more detailed configuration will be found in the old posts.

2007/08/24 - [computer/linux] - gsview on ubuntu linux (6.10)
2008/01/01 - [computer/linux] - Gtk-WARNING **: Unable to locate loadable module in module_path


Installation

make install

more



Modification

emacs /usr/local/bin/gsview-help &

#!/bin/sh
# This script runs the GSview help
# $1 is the help file name
# $2 is the topic name

if [ -z "$1" ]
then
  echo "Usage: $0 URL [TAG]"
  echo "  URL: The URL to open"
  echo "  TAG: The anchor at that url"
  exit 1
fi

if [ -z "$2" ]
then
  TAG=''
else
  TAG="#$2"
fi

if mozilla -remote openFile\(file://$1$TAG\) ; then
    exit 0
else
    mozilla file://$1$TAG
fi
exit 0

you should change mozilla to firefox .
posted by citadel

2009/03/13 - [computer/linux] - gsview on Ubuntu Hardy (8.04.02)


#wget -c ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/gsview-4.8-1.i386.rpm

#alien  gsview-4.8-1.i386.rpm
#dpkg -i gsview_4.8-2_i386.deb

#gsview (run gsview)
Error message: empty message box
solution:  go to -> Option -> Ignore DSC

#gsview
Now the error messages as follows:

GSview 4.8 2006-02-25
play_sound: not implemented
debug=0
Failed to load libgs.so: libgs.so: cannot open shared object file: No such file or directory
Can't load Ghostscript DLL

Search the correct library for gsview
# apt-cache search libgs* |grep Ghost*
libgs-esp-dev - The Ghostscript PostScript Library - Development Files
libgs-esp8 - The Ghostscript PostScript Library

Install the libgs-esp8
# apt-get install libgs-esp8
Check the path of that library
# ls /usr/lib/libgs-*
/usr/lib/libgs-esp.so.8.15

Two main problems are the library name and the font path.
solutions :
1) Using the Options
go to -> Option -> Advanced Configure
    > Ghostscript Shared Object
      rename libgs.so to libgs-eps.so.8.15   
    > Ghostscript Version
      change a proper version which you use
      for example, 704 -> 850
    > Ghostscript Options:
        input the correct fonts path
       -sFONTPATH="/usr/share/fonts/
      
   
2) Using the configuration file
   open .gsview.ini in $HOME directory
   go [GSview-4.8] line
   [GSview-4.8]
   Version=4.8
   GSversion=850
   Configured=1
   GhostscriptDLL=libgs-esp.so.8.15
   GhostscriptEXE=gs
   GhostscriptInclude=
   GhostscriptOther=-sFONTPATH="/usr/share/fonts/

     
Error message: No page numbering available!
solution: 
   @ go to   Option ->
       Off EPS-clip
       Off EPS Warn
       Off Ignore DSC
       Off Show Boundig Box
   @  go to   Option -> DSC Warning ->
       
Off


.gsview.ini file in my $HOME directory is
 

more.. gsview.ini


'Computer > linux' 카테고리의 다른 글

Firefox ugly font size with Xfce4  (0) 2007.08.27
gsview on ubuntu linux (6.10)  (0) 2007.08.25
xfce4 WM  (0) 2007.08.23
ntpdate and ntp  (0) 2007.08.16
posted by citadel