If one executes the thunderbird 32bit on 64bit machine, one could see the following error message:

(thunderbird:19701): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64


So I download the 64bit version thunderbird via http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/linux-x86_64/en-US/

No error messages are displayed when I execute it.

'Computer > linux' 카테고리의 다른 글

BIOS update with bootable CD (Linux)  (0) 2012.09.27
thunderbird 64 bit version  (0) 2012.09.25
change an existing user shell in CLI  (0) 2012.08.29
when sound-juicer refuses to mount an audio cd  (0) 2012.08.28
posted by citadel

Get the Java (jdk) and extract jdk  into /usr/lib/jvm/

$ tar xvzf  jdk-7u5-linux-x64.tar.gz

$ update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_05/bin/java 1065

$ update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.7.0_05/bin/javac 1065

$ update-alternatives --config java

There are 4 choices for the alternative java (providing /usr/bin/java).


  Selection    Path                                      Priority   Status

------------------------------------------------------------

* 0            /usr/lib/jvm/jdk1.7.0_05/bin/java          1065      auto mode

  1            /usr/bin/gij-4.4                           1044      manual mode

  2            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1061      manual mode

  3            /usr/lib/jvm/java-6-sun/jre/bin/java       63        manual mode

  4            /usr/lib/jvm/jdk1.7.0_05/bin/java          1065      manual mode


Finally, replace the symbolic link for mozilla plugin via

 ln -sf /usr/lib/jvm/jdk1.7.0_05/jre/lib/amd64/libnpjp2.so  /etc/alternatives/mozilla-javaplugin.so


'Computer > linux' 카테고리의 다른 글

RTL8188ce Wireless on Debian Wheezy  (0) 2012.07.25
Install Java 7 on Debian 6  (0) 2012.07.05
automatic usb mount in Debian  (0) 2012.07.04
Business card with QR-code and vcard by using Latex  (0) 2012.07.02
posted by citadel

Recently,Amazon updated their prime instant video player to use a recent Adobe flash. So I cannot watch video anymore. I can install the flash player myself, but I don't want to introduce user-customized thing into the super stable Debian 6. 

$ aptitude show flashplugin-nonfree
Package: flashplugin-nonfree            
New: yes
State: installed
Automatically installed: no
Version: 1:2.8.2
Priority: optional
Section: contrib/web
Maintainer: Bart Martens <bartm@debian.org>
Uncompressed Size: 135 k
Depends: debconf | debconf-2.0, wget, gnupg, libatk1.0-0, libcairo2, libfontconfig1, libfreetype6, libgcc1, libglib2.0-0, libgtk2.0-0, libnspr4-0d, libnss3-1d, libpango1.0-0, libstdc++6, libx11-6, libxext6, libxt6, libcurl3-gnutls

Suggests: iceweasel, konqueror-nsplugins, x-ttcidfont-conf, msttcorefonts, ttf-dejavu, ttf-xfree86-nonfree, flashplugin-nonfree-extrasound
Conflicts: flashplayer-mozilla, flashplugin (< 6), libflash-mozplugin, xfs (< 1:1.0.1-5)
Replaces: flashplugin (< 6)
Description: Adobe Flash Player - browser plugin
 This package will download the Flash Player from Adobe.  It is a Netscape/Mozilla type plugin.  Any browser based on Netscape or Mozilla can use the Flash Player.  This package currently supports the following browsers: Mozilla, Mozilla-Firefox, Firefox, Iceweasel, and Iceape.  Also Galeon and Epiphany can use the Flash Player.  Konqueror can also use the Flash Player if konqueror-nsplugins is installed.
 
 WARNING: Installing this Debian package causes the Adobe Flash Player to be downloaded from www.adobe.com. The End User License Agreement of the Adobe Flash Player is available at www.adobe.com.Homepage: http://wiki.debian.org/FlashPlayer

After looking at this package description, - will download the Flash Player from Adobe, I've got an idea to re-install the Flash Player from Adobe.


aptitude remove  flashplugin-nonfree

aptitude install  flashplugin-nonfree

HTTP request sent, awaiting response... 200 OK
Length: 6916435 (6.6M) [application/x-gzip]
Saving to: “./install_flash_player_11_linux.i386.tar.gz”

     0K .......... .......... .......... .......... ..........  0%  252K 27s
    50K .......... .......... .......... .......... ..........  1% 31.3K 2m0s
   100K .......... .......... .......... .......... ..........  2%  131K 96s
   150K .......... .......... .......... .......... ..........  2%  228K 79s
   200K .......... .......... .......... .......... ..........  3%  216K 68s
   250K .......... .......... .......... .......... ..........  4%  262K 61s
   300K .......... .......... .......... .......... ..........  5%  291K 55s
   350K .......... .......... .......... .......... ..........  5%  319K 50s
..................

 6700K .......... .......... .......... .......... .......... 99%  345K 0s
  6750K ....                                                  100%  439K=26s

2012-06-01 13:01:57 (261 KB/s) - “./install_flash_player_11_linux.i386.tar.gz” saved [6916435/6916435]

Great!  This flashplugin-nonfree can download the most recent player from Adobe. I can watch movies from Amazon now. :-)

posted by citadel